petsc

PETSc: Portable, Extensible Toolkit for Scientific Computation

Installation

In a virtualenv (see these instructions if you need to create one):

sudo apt install libudev1 libxdmcp6 libxau6 libgfortran5 libopenmpi3 libbsd0 libmd0 libx11-6 libopenblas0-pthread libhwloc15 libevent-pthreads-2.1-7 libevent-core-2.1-7 libstdc++6 libxcb1
pip3 install petsc

Releases

Version Released Buster
Python 3.7
Bullseye
Python 3.9
Bookworm
Python 3.11
Files
3.21.2 2024-05-30      
3.21.1 2024-04-29      
3.21.0 2024-04-02      
3.20.5 2024-02-28      
3.20.4 2024-01-30      
3.20.3 2023-12-31      
3.20.2 2023-12-10      
3.20.1 2023-10-31      
3.20.0 2023-10-04      
3.19.6 2023-10-03      
3.19.5 2023-08-31      
3.19.4 2023-08-02      
3.19.2 2023-06-30      
3.19.1 2023-05-01      
3.19.0 2023-04-02      
3.18.5 2023-02-28      
3.18.4 2023-02-04      
3.18.3 2022-12-30      
3.18.2 2022-11-30      
3.18.1 2022-11-02      
3.18.0 2022-10-07      
3.17.4 2022-08-02      
3.17.3 2022-07-03      
3.17.2 2022-06-05      
3.17.1 2022-05-19      
3.17.0 2022-04-08      
3.16.6 2022-04-01      
3.16.5 2022-03-15      
3.16.4 2022-03-15      
3.16.3 2022-03-15      
3.16.2 2022-03-15      
3.16.1 2021-11-19      
3.16.0 2021-10-03      
3.15.4 2021-09-03      
3.15.3 2021-08-15      
3.15.2 2021-08-15      
3.15.1 2021-06-18      
3.15.0 2021-04-02      
3.14.5 2021-03-04      
3.14.4 2021-02-04      
3.14.3 2021-01-10      
3.14.2 2020-12-04      
3.14.1 2020-11-05      
3.14.0 2020-10-13      
3.13.5 2020-09-02      
3.13.4 2020-08-04      
3.13.3 2020-07-03      
3.13.2 2020-06-03      
3.13.1 2020-05-04      
3.13.0 2020-04-04      
3.12.5 2020-03-30      
3.12.4 2020-02-05      
3.12.3 2020-02-05      
3.12.2 2019-11-23      
3.12.1 2019-11-23      
3.12.0 2019-10-11      
3.11.1 2019-04-14      
3.11.0 2019-04-14      
3.10.3 2019-01-27      
3.10.0 2018-09-16      
3.9.2 2018-05-27      
3.9.1 2018-05-02      
3.9.0 2018-04-22      
3.8.1 2017-11-05      
3.8.0 2017-10-02      
3.7.6 2017-07-28      
3.7.2 2016-06-06      
3.7.1 2016-06-01      

Issues with this package?

Page last updated 2024-05-30 08:10:12 UTC